Search Home Members Contacts
About Us
Products
Downloads
Community
Support
Bug #776: Problem with last release
Product:
TV3D SDK 6.5
Language:
Not Specified
Current State:
Closed
Resolution:
Fixed
Created On:
September 23rd, 2007
Last Modified:
September 25th, 2007
Reported By:
Sethergal
I switched on last release some time ago and
everything worked fine. A few day ago every
application that use that release stop working.
Even Model Viewer which is in this SDK.
I tried to reinstall DXSDK, TV3DSDK and
redistribution for VS2005.

When I tried to start older copy application (use older release) everything work fine in there.

Error in my program (C++) in line with:
m_pTVEngine->Init3DWindowed(m_hWindowHandle,false);

Error:
Unhandled exception at 0x01b06a13 in Game.exe: 0xC0000005: Access violation writing location 0x02b01000.

Debug file:
09-23-2007 17:41:40 | --------------------------------------------
09-23-2007 17:41:40 | Truevision3D Debug/Log File
09-23-2007 17:41:40 | --------------------------------------------
09-23-2007 17:41:40 | Engine Version : 6.5
09-23-2007 17:41:40 | ENGINE INFO : DLL Compilation time Sep 2 2007 12:47:32

The same error is when I try to start in full screen mode (by: Init3DFullscreen(...)). I know that maybe it's fault of configuration on my computer but that is weird that it stop working without any specific reason.

Comments:

Posted by darqSHADOW on September 24th, 2007 at 1:45 AM
More information will be required to solve this. Which setup did you install? Which DLL are you using? Have you run depends.exe against the DLL to ensure you are not missing files locally? Can you send a sample project that reproduces the problem?
Posted by Sethergal on September 24th, 2007 at 2:51 AM
I will start from last question:
No because this happening only on my computer. On computer of second programmer it's work fine. About program to check as I write even ModelViewer, particleeditor, SFxE that are in your SDK not work. Our written application is in C++ so I use there TV3D65.dll and it's the same.


About Depends.exe I have in there only one warning:
"Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module."
And it's WNetRestoreConnectionA in file MPR.dll

About setup that I use: Sep 2 2007 I downloaded now new version from: Sep 23 2007 16:59:26 and still the same problem.
Posted by darqSHADOW on September 25th, 2007 at 10:11 PM
New setups are available with fixed DLL's.
Posted by Sethergal on September 26th, 2007 at 1:00 AM
That not helped. But after today looking I find out that problem was in license. I downloaded new LicenseSign and generate new *.lic file. And now everything is fine. But it's weird because I always try to download newest version of library and I don't remember that LicenseSign was changed or any information about generating *.lic once again.

I searched more and find out that if I have the same license copy (for example) in directory:
E:Program
and use function:
m_pTVEngine->SetLicenseFile("E:\Program\Angelus.lic");
Truevision give me the same error as before.