Search Home Members Contacts
About Us
Products
Downloads
Community
Support
Bug #431: SetAutoResize no longer works
Product:
TV3D SDK 6.5
Language:
Not Specified
Current State:
Closed
Resolution:
Fixed
Created On:
June 21st, 2005
Last Modified:
July 7th, 2005
Reported By:
Tv.GetViewport.SetAutoResize(True);

If I resize the window I get a nasty access violation in the dll. I've tried this in clean code also, same thing. It worked in the old dll.

Comments:

Posted by SylvainTV on June 25th, 2005 at 2:20 PM
Well, it maybe means that one object does not get released correctly.
It seems to work with a simple landscape here.

Can you sum up what is in what you tried ?
It must be linked to one feature only i think.
Posted by on June 28th, 2005 at 4:25 PM
Here are all the objects I was using:

LightEngine: TvLightEngine;
Globals : TvGlobals;
Actor : TvActor;
Scene : TvScene;
Math : TvMathLibrary;
Mats : TvMaterialFactory;
Mesh : TvMesh;
Cam : TvCamera;
Inp : TvInputEngine;
Sky : TvMesh;
Tex : TvTextureFactory;
Fx : TvGraphicEffect;
Rs : TvRenderSurface;
Tv : TvEngine;

Light1, Light2, Light3, Light4: Integer;

The lights are all points. Its just a little app which loads a TVA and allows me to import new anims. Nothing really complex. If you want me to send it just give the word.
Posted by SylvainTV on June 30th, 2005 at 10:45 AM
Its usually a object not released problem.. very annoying to track it down

If you don't see any problem with sending it to me, it would be nice :)
This way i just look up what object is not released, and fix that directly :)

Thanks
Posted by on July 2nd, 2005 at 12:24 AM
Sent ;)
Posted by SylvainTV on July 7th, 2005 at 3:08 PM
Thanks, fixed.

It had to do with input manager weirdly :p It maybe fixed the problems with weird mouse in fullscreen when you switch too :)